We have confirmed that the issue impacting NexCloud login has been resolved. Our team will continue to monitor the situation closely as efforts turn to completing a full root cause analysis. If your practice is still encountering any related issues, please don’t hesitate to contact Support. Thank you for your patience.
Posted Feb 13, 2026 - 16:28 EST
Monitoring
The team has observed continued improvement with user logins, and no new issues have been reported. We are actively monitoring the situation while continuing to work with Microsoft Support to ensure stability.
Posted Feb 13, 2026 - 12:23 EST
Update
Users may be able to successfully connect after retrying. Our team is working closely with Microsoft Support to fully resolve the root cause. We will continue to provide updates as more information becomes available.
Posted Feb 13, 2026 - 12:03 EST
Identified
The team has identified the issue and is working diligently to provide a resolution. We understand the impact this may have on your practice and will continue to treat this as our top priority until it is resolved. If you are experiencing a problem, please disconnect your session completely and try again.
Posted Feb 13, 2026 - 11:15 EST
Investigating
We are currently investigating login issues with NexCloud affecting a subset of our customers. If you are experiencing a problem, please disconnect your session completely and try again.