Practice + Appointment Reminders are sporadically not sending

Incident Report for Nextech

Update

We have resolved most of the issues and are continuing to monitor.
Posted Sep 17, 2025 - 11:29 EDT

Monitoring

We have released a fix and will continue to monitor the issue throughout the remainder of today and tomorrow.
Posted Sep 16, 2025 - 16:50 EDT

Update

We've identified the issue and are working through a resolution.
Posted Sep 16, 2025 - 10:38 EDT

Update

We are continuing to work on a fix for this issue.
Posted Sep 15, 2025 - 12:42 EDT

Update

We are continuing to work on a fix for this issue.
Posted Sep 15, 2025 - 08:46 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 12, 2025 - 16:50 EDT

Investigating

Appointment Reminders are being sent sporadically. We are currently investigating the issue.
Posted Sep 12, 2025 - 15:04 EDT
This incident affects: Nextech Practice Management (powered by Practice+).