Ensora Health /Newcrop Connectivity Issues

Incident Report for Nextech

Resolved

This incident has been resolved.
Posted Feb 18, 2026 - 12:53 EST

Monitoring

Incident status: Monitoring

The issue has been identified by Ensora and they are seeing the system performance restored and connectivity times improve. They are continuing to evaluate and monitor the situation
Posted Feb 18, 2026 - 11:19 EST

Investigating

Ensora Health (Newcrop) is currently investigating an issue that may result in connectivity issues, including timeouts and slowdowns. This may result in 503 or 504 errors Please Visit https://status.ensorahealth.com/ for updates
Posted Feb 18, 2026 - 10:32 EST
This incident affected: Nextech NexCloud.