Newcrop ERX issues
Incident Report for Nextech
Resolved
This incident has been resolved.
Posted Nov 11, 2024 - 16:01 EST
Update
We are continuing to monitor for any further issues.
Posted Nov 11, 2024 - 15:45 EST
Monitoring
Latest update from Newcrop: Monitoring - The primary issue has been resolved and the prescriptions are now processing normally. Prescription transmission details may not be immediately available and should be restored in the near future as the update completes.
Nov 11, 2024 - 13:09 EST please visit https://status.newcroprx.com/ for realtime updates
Posted Nov 11, 2024 - 13:14 EST
Investigating
Newcrop is currently experiencing issues with their eprescribing system. please visit https://status.newcroprx.com/ for updates
Posted Nov 11, 2024 - 12:58 EST
This incident affected: Nextech NexCloud.