We are experiencing issues with Dr First ePrescribing

Incident Report for Nextech

Resolved

All traffice to Dr First have returned to normal.
Posted Aug 22, 2025 - 13:09 EDT

Monitoring

Dr First has deployed a fix, and we are seeing improvements. We will continue to monitor the fix.
Posted Aug 22, 2025 - 12:47 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 22, 2025 - 11:12 EDT

Investigating

We have identified the issue and working on a resolution.
Posted Aug 22, 2025 - 10:42 EDT
This incident affected: Nextech NexCloud.