Practice Plus Performance Issues

Incident Report for Nextech

Resolved

This incident has been resolved.
Posted Aug 25, 2026 - 17:22 EDT

Monitoring

A corrective action has been implemented to address the performance degradation.

System performance has improved and services are operating normally. We are actively monitoring the environment to ensure continued stability.

Customers should see normal application responsiveness. We will continue monitoring before closing this incident
Posted Aug 25, 2026 - 15:49 EDT

Update

We are still continuing to deploy corrective actions to address the performance degradation
Posted Aug 25, 2026 - 14:20 EDT

Update

We are continuing to deploy corrective actions to address the performance degradation.
Posted Aug 25, 2026 - 12:40 EDT

Update

We are continuing to work on the fix for the issue.
Posted Aug 25, 2026 - 11:25 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 25, 2026 - 10:43 EDT

Investigating

We are currently Investigating issues with performance issues affecting a subset of clients in Practice Plus
Posted Aug 25, 2026 - 10:15 EDT
This incident affected: Nextech Practice Management (powered by Practice+).