issues switching practices in Intellechart Pro

Incident Report for Nextech

Resolved

This issue has been resolved
Posted 12 days ago. Mar 24, 2025 - 11:19 EDT

Investigating

We are currently investigating issues with switching practices in our Intellechart platform
Posted 12 days ago. Mar 24, 2025 - 09:58 EDT
This incident affected: Nextech EHR (powered by IntelleChartPRO).