TouchMD apps and websites not responding

Incident Report for Nextech

Resolved

This incident has been resolved.
Posted Aug 07, 2025 - 09:52 EDT

Update

We are continuing to investigate this issue.
Posted Aug 06, 2025 - 13:56 EDT

Investigating

We are currently investigating issues with our TouchMD apps and website
Posted Aug 06, 2025 - 13:46 EDT
This incident affected: TouchMD.