P+ Login Error

Incident Report for Nextech

Resolved

Monitoring and validation activities have been successfully completed.

The issue affecting P+ has been resolved, and service is operating normally. Customers should no longer experience the previously reported impact.

We appreciate your patience while we worked to restore service.
Posted Aug 25, 2026 - 08:40 EDT

Monitoring

A corrective action has been implemented for the issue affecting P+.

Service functionality has been restored, and we are actively monitoring system performance to ensure stability and confirm that the issue has been fully resolved.

We will continue monitoring and provide confirmation once validation activities have been completed.
Posted Aug 25, 2026 - 08:07 EDT

Investigating

We have identified the cause of the issue and are working on a resolution.

While work is ongoing, some customers may continue to experience some login issues. We are prioritizing restoration efforts and closely monitoring the environment.

Our next update will be provided once implementation progress has been confirmed.
Posted Aug 25, 2026 - 08:04 EDT

Identified

We have identified the cause of the issue affecting P+.

Customers may experience login issues while we work toward a resolution. Our team is actively working to restore normal service as quickly as possible.

We will continue to provide updates on our progress.
Posted Aug 25, 2026 - 08:01 EDT

Update

We are continuing to investigate this issue.
Posted Aug 25, 2026 - 07:46 EDT

Investigating

We are currently investigating the issue with the P+ login errors.
Posted Aug 25, 2026 - 07:45 EDT
This incident affected: Nextech Practice Management (powered by Practice+).