Performance Degradation

Incident Report for Nextech

Resolved

This incident has been resolved.
Posted Jul 23, 2026 - 16:45 EDT

Update

Microsoft identified a recent change that was strongly correlated with the onset of impact. They have completed the rollback of this change and telemetry across services are continuing to show signs of recovery.

Performance has improved and services are operating normally. We are actively monitoring the environment to ensure continued stability.
Posted Jul 23, 2026 - 15:01 EDT

Update

Microsoft appears to have identified the likely cause of the issue and is actively rolling out mitigation measures. Based on their current progress, additional information on how effective these measures are within approximately 30 minutes.
Posted Jul 23, 2026 - 14:12 EDT

Monitoring

Microsoft is currently implementing mitigation actions and are seeing positive indications toward recovery. They do not have a confirmed ETA yet, but progress is being made.
Posted Jul 23, 2026 - 14:00 EDT

Identified

We have identified the cause of the service disruption affecting TouchMD.

Customers may continue to experience an inability to access the application or complete normal workflows while remediation efforts are underway.

Microsoft has confirmed Connectivity Issues Affecting Azure Services in West US.

https://azure.status.microsoft/en-us/status

We will continue to provide updates on our progress.
Posted Jul 23, 2026 - 12:03 EDT
This incident affected: TouchMD.