Degraded Performance – SRSPro RemoteApp Access

Incident Report for Nextech

Resolved

This incident has been resolved.
Posted May 18, 2026 - 13:21 EDT

Monitoring

A fix has been implemented, and we are monitoring the results.
Posted May 18, 2026 - 12:14 EDT

Identified

Our teams are actively working to stabilize connectivity. While some users are able to connect successfully, intermittent issues may persist as we continue mitigation efforts.
Posted May 18, 2026 - 11:24 EDT

Investigating

We are currently investigating reports of intermittent connectivity issues impacting access to SRSPro via RemoteApp.
Posted May 18, 2026 - 10:16 EDT
This incident affected: Nextech SRSPro Hosted.