Performance Degradation

Incident Report for Nextech

Resolved

This incident has been resolved.
Posted Jul 31, 2026 - 10:17 EDT

Monitoring

A corrective action has been implemented to address the performance degradation.

System performance has improved and services are operating normally. We are actively monitoring the environment to ensure continued stability.

Customers should see normal application responsiveness. We will continue monitoring before closing this incident
Posted Jul 31, 2026 - 09:29 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 31, 2026 - 09:24 EDT

Investigating

We are investigating reports of degraded performance. Customers may experience intermittent errors, slower-than-normal response times, or delays when performing certain actions.

We will provide additional updates as more information becomes available.
Posted Jul 31, 2026 - 09:18 EDT
This incident affected: Nextech Practice Management (powered by Practice+).