Login Issues - Nextech PM and EMR
Incident Report for Nextech
Resolved
This incident has been resolved.
Posted Jul 26, 2024 - 16:05 EDT
Monitoring
A fix has been implemented. We are closely monitoring the results.
Posted Jul 26, 2024 - 15:23 EDT
Update
we are continuing work on the issue and are seeing a reduced amount of login errors.
Posted Jul 26, 2024 - 15:17 EDT
Identified
we have identified the issue and are actively resolving
Posted Jul 26, 2024 - 14:54 EDT
Investigating
We are currently investigating and issue with logins for our Nextech PM and EMR systems
Posted Jul 26, 2024 - 14:35 EDT
This incident affected: Nextech EHR (powered by IntelleChartPRO) and Nextech Practice Management (powered by Practice+).