Incident Reported

Incident Report for Nextech

Resolved

This incident has been resolved.
Posted Aug 27, 2026 - 14:03 EDT

Monitoring

The emergency maintenance has been completed, and service has been restored.

Customers who were impacted should now be able to log in and resume normal operations.

We will continue to monitor the environment closely to ensure stability.
Posted Aug 27, 2026 - 11:06 EDT

Identified

We are aware of an issue impacting a subset of users who may be unable to log in or may experience connectivity issues. Our teams have identified the affected services and are performing emergency maintenance to restore normal operation.

During this maintenance window, affected users may experience a brief interruption in service. We are actively working to restore service as quickly as possible and will provide additional updates as they become available.
Posted Aug 27, 2026 - 10:28 EDT

Investigating

We are investigating reports of multiple issues affecting our Nexcloud product.

Our team is actively working to determine the cause and assess the scope of impact. We will provide additional updates as more information becomes available.

We apologize for the disruption and appreciate your patience.
Posted Aug 27, 2026 - 09:26 EDT
This incident affected: Nextech NexCloud.