Performance Issue

Incident Report for Nextech

Resolved

Performance remains stable, and this incident has now been resolved.
Posted Jan 22, 2026 - 10:29 EST

Monitoring

A fix has been implemented, and we are currently monitoring the results to ensure system performance and stability return to normal.
Posted Jan 21, 2026 - 11:37 EST

Identified

The intermittent slowness has improved, but performance has not yet fully returned to normal. We continue to work toward a full resolution.
Posted Jan 21, 2026 - 11:32 EST

Investigating

We are currently investigating a performance issue that is causing intermittent slowness and error messages.
Posted Jan 21, 2026 - 10:33 EST
This incident affected: Nextech Practice Management (powered by Practice+).