Login & Application Access Issues

Incident Report for Nextech

Resolved

This incident has been resolved.
Posted May 19, 2026 - 22:05 EDT

Monitoring

The issue has been resolved and systems are stable. We are actively monitoring to ensure continued performance.
Posted May 19, 2026 - 21:50 EDT

Update

We're actively working on restoration. Progress is being made, and we’ll continue to share updates as we move toward resolution.
Posted May 19, 2026 - 20:38 EDT

Update

We are still working on putting the fix in place.
Posted May 19, 2026 - 19:11 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 19, 2026 - 18:13 EDT

Investigating

We are currently investigating an issue impacting application access for multiple customers.
Posted May 19, 2026 - 17:46 EDT
This incident affected: Nextech Practice Management (powered by Practice+).