TriZetto Eligibility Outage

Incident Report for Nextech

Resolved

TriZetto has confirmed that services have been restored.
Posted Mar 06, 2026 - 15:27 EST

Monitoring

TriZetto is currently experiencing an outage impacting eligibility transactions. As a result, users may experience slowness or errors when saving a policy or checking eligibility.

TriZetto is actively working to resolve the issue and will provide updates as they become available.
Posted Mar 06, 2026 - 14:43 EST
This incident affected: Nextech Practice Management (powered by Practice+).