Third-party communications provider degradation

Incident Report for Nextech

Resolved

This incident has been resolved. All services are fully restored and operating normally.
Posted Aug 26, 2026 - 14:57 EDT

Update

The third-party communications provider has reported seeing signs of recovery, and performance is improving. While systems continue to stabilize, some users may still notice occasional slowness and other intermittent instability.
Posted Aug 26, 2026 - 12:41 EDT

Monitoring

A third-party communications provider has reported service degradation that may impact patient communication workflows for some Practice+ and Select Nextech Cloud customers.

We are actively monitoring the provider's status and engaging with their team for updates.
Posted Aug 26, 2026 - 12:24 EDT
This incident affected: Nextech Practice Management (powered by Practice+) and Nextech NexCloud.