Nexcloud IPAD connectivity Issues

Incident Report for Nextech

Resolved

This incident has been resolved.
Posted Oct 13, 2025 - 09:12 EDT

Monitoring

A fix has been implemented and we are monitoring the results. If you are still having issues connecting your Ipad App, please update your app from the App Store to version 3.03
Posted Oct 11, 2025 - 19:34 EDT

Investigating

We are currently investigating an issue with Nexcloud Ipad Connectivity.
Posted Oct 11, 2025 - 18:04 EDT
This incident affected: Nextech NexCloud.