Application errors loading charts 5/12

Incident Report for Nextech

Resolved

This incident has been resolved.
Posted 1 month ago. May 12, 2025 - 15:54 EDT

Investigating

We are investigating issues with a subset of clients getting application errors loading charts
Posted 1 month ago. May 12, 2025 - 14:57 EDT
This incident affected: Nextech EHR (powered by IntelleChartPRO).