Login Issues

Incident Report for Nextech

Resolved

This incident has been resolved.
Posted Jun 05, 2026 - 09:46 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 05, 2026 - 08:46 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 05, 2026 - 08:25 EDT

Investigating

We are currently investigating an issue impacting NexCloud. Users may be unable to log in at this time. Our teams are actively working to identify the cause and restore access as quickly as possible.
Posted Jun 05, 2026 - 07:49 EDT
This incident affected: Nextech NexCloud.