Arbimed Inventory Issues

Incident Report for Nextech

Resolved

This incident has been resolved.
Posted Jun 26, 2025 - 14:04 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 26, 2025 - 13:22 EDT

Investigating

We are investigating an issue affecting a subset of customers that utilize Arbimed inventory. Customers may receive a blank page or error when loading the inventory list. We are working to identify the root cause.
Posted Jun 26, 2025 - 12:44 EDT
This incident affected: Nextech Practice Management (powered by Practice+).