AWS systems appear to be fully back online for those zones impacting Nextech clients. We will continue to monitor the situation until full resolution, but we do not expect any further impact on Nextech products.
Posted Oct 20, 2025 - 17:24 EDT
Update
AWS recovery continues to improve, and we continue to monitor for any issues.
Posted Oct 20, 2025 - 15:53 EDT
Update
We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 12:43 EDT
Monitoring
Nextech systems are still operational, but some services may experience degradation, including access to some features or optional preferences. US systems are slowly returning to normal operation, but some regions are still impacted. We are monitoring AWS system status. https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 12:32 EDT
This incident affected: Nextech EHR (powered by IntelleChartPRO), Nextech Practice Management (powered by Practice+), Nextech NexCloud, Nextech SRSPro Hosted, and TouchMD.