Intermittent ICP Slowness/Loading

Incident Report for Nextech

Resolved

This has been resolved and we are continuing to monitor the performance.
Posted Aug 14, 2026 - 10:07 EDT

Monitoring

We are seeing continued improvements within the system and are continuing to monitor performance at this time.
Posted Aug 14, 2026 - 10:01 EDT

Update

We are seeing improvements within the system and are continuing to monitor performance at this time.
Posted Aug 14, 2026 - 09:55 EDT

Investigating

We are currently investigating intermittent issues within our ICP platform.
Posted Aug 14, 2026 - 08:08 EDT
This incident affected: Nextech EHR (powered by IntelleChartPRO).